reo101
2941536b80
Also stop passing `outputs` around, prefer `inputs.self` Also put all `auto_` in `readOnly` `internal` options - `autoModules`, `autoConfigurations` and `autoPackages` Do not export packages as overlay (causes an infinite recursion) - this is documented on the two places it has effect on -- in `./overlays/default.nix` and `./modules/flake/configurations.nix` -- in `autoConfigurations` we manually extend `pkgs` with the flake packages Allow packages to say what `systems` they are compatible with - See `./pkgs/swww/systems.nix` - disabled for all systems - See `./pkgs/pngpaste/systems.nix` - enabled only for `darwin` targets
30 lines
629 B
Nix
30 lines
629 B
Nix
{ inputs, ... }:
|
|
{ lib, pkgs, config, ... }:
|
|
|
|
{
|
|
imports = [ ];
|
|
|
|
options = { };
|
|
|
|
config = {
|
|
# # Add flake inputs to $NIX_PATH
|
|
# home.sessionVariables = {
|
|
# NIX_PATH =
|
|
# builtins.concatStringsSep
|
|
# ":"
|
|
# (lib.mapAttrsToList
|
|
# (name: input:
|
|
# "${name}=${input.sourceInfo.outPath}")
|
|
# inputs);
|
|
# };
|
|
|
|
# NOTE: now automatic, since we're doing `useGlobalPkgs = true`
|
|
#
|
|
# # Use flake overlays by default
|
|
# nixpkgs = {
|
|
# overlays = lib.attrValues inputs.self.overlays;
|
|
#
|
|
# config.allowUnfree = true;
|
|
# };
|
|
};
|
|
}
|